Intermittent Account Access and Management Issues

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with intermittent errors with account-level actions, including management and settings changes, as well as other account-specific functions such as login-related activity has been resolved. All services are now operating normally at this time.
Posted Apr 06, 2026 - 14:45 PDT

Update

Our engineers are continuing to monitor the fix for the issue causing intermittent errors with account-level actions, including management and settings changes, as well as other account-specific functions such as login-related activity. At this time, there is no new information to share.

Mail send is not impacted.

We will provide another update as soon as more information becomes available.
Posted Apr 06, 2026 - 10:57 PDT

Monitoring

Our engineers have implemented a fix for the issue causing intermittent errors with account-level actions, including management and settings changes, as well as other account-specific functions such as login-related activity. We are now monitoring to ensure the fix is working as expected.

Mail send is not impacted.

We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 06, 2026 - 08:30 PDT

Investigating

Starting around 7:44 AM PT on April 6, 2026, our engineers began investigating an issue causing intermittent errors with account-level actions. This affects management and settings changes, as well as other account-specific functions such as login-related activity. Customers may experience intermittent failures when attempting to update account settings, manage their accounts, or log in.

Mail send is not impacted.

We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 06, 2026 - 08:08 PDT
This incident affected: API and Website.