Mail Delivery Delays in Asia Pacific Region
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with mail delivery delays has been resolved. All services are now operating normally at this time, so we'll close this incident to Resolved. Thank you for your understanding.
Posted Sep 10, 2024 - 07:21 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance, we are seeing an improved performance overall and all messages are now being delivered without any delay. We will provide another update within the next minutes once we can confirm the issue has been resolved correctly.
Posted Sep 10, 2024 - 07:00 PDT
Identified
Our engineers have identified the root cause of the issue and continue testing possible fixes. At this time, customers could have experienced delays in Asia Pacific mail send requests from 1:24 am PT to 2:06am. New traffic continues to be swung away from Asia Pacific, and we do not expect delays to new mail sends after 2:06am PT. The stuck mails were all delivered by 6:12am PDT. Additionally, we identified another impact for degraded mail send API availability from 1:24am PDT to 2:52am PDT. It's mitigated by further swinging traffic away from Oceania at 2:48am PDT

We will provide another update within an hour or as soon as more information becomes available.
Posted Sep 10, 2024 - 05:57 PDT
Investigating
Our engineering team have identified mail delivery delays occurring in the Asia Pacific region. We are actively working to resolve. As a result, these emails may experience extended delivery times. We will continue to monitor the situation and provide updates while we work to clear the backlog.
Posted Sep 10, 2024 - 04:24 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).