Email Sending Delay
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with email sends has been resolved. All services are now operating normally at this time.
Posted Sep 02, 2024 - 09:22 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 02, 2024 - 09:05 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2024 - 07:34 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 02, 2024 - 07:33 PDT
Investigating
Starting around 6:15 AM PT, our began receiving reports regarding issues with mail send delays. Customers may receive 5xx errors or Internal Server Errors when attempting to send mail via API call or through SMTP. Customers may notice mail send delays. We will provide updates in the next 1 hour or sooner as they become available.
Posted Sep 02, 2024 - 06:40 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).