Retroincident - Temporary Click Tracking degraded performance

Incident Report for SendGrid

Resolved

Starting around 10.05 PT, June 30th, our engineers discovered an issue with Click Tracking where intermittent errors around our links were occurring. Links were not resolving correctly, however, customers just need to retry to make the links work.

No data loss has been discovered as long as the link worked.

Mail send was not affected.

Issue has been quickly remediated, a fix has been implemented, no new issues have been reported from our end, and no new reports from customer have been reported. This issue is now resolved.
Posted Jun 30, 2025 - 10:00 PDT