Increased rates of 502 errors on Twilio SendGrid docs and code-exchange pages

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with increased rates of 502 errors on Twilio SendGrid docs and code-exchange pages has been resolved. All services are now operating normally at this time.
Posted Sep 07, 2025 - 00:25 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance.
Posted Sep 06, 2025 - 23:40 PDT

Update

We are continuing to investigate this issue.
Posted Sep 06, 2025 - 23:21 PDT

Investigating

Starting around 10:45 PM PST on September 6th, 2025, our engineers began investigating an issue where we see increased rates of 502 errors on Twilio SendGrid docs and code-exchange pages. Users may experience 502 errors while accessing the docs during this time. This does not impact mail send. We will provide another update as soon as more information becomes available.
Posted Sep 06, 2025 - 23:03 PDT