After monitoring the implemented fix, we have confirmed the issue is resolved and systems are stable. You should now be able to update your payment method successfully. If you have any questions or encounter further issues, please contact our Support Team for further assistance.
Posted Sep 16, 2025 - 10:50 PDT
Monitoring
A fix has been implemented and we are monitoring the results. Please try updating your payment method again, and let us know if you continue to experience any difficulties.
Posted Sep 16, 2025 - 01:01 PDT
Update
The issue has been resolved. Please try updating your payment method again, and let us know if you continue to experience any difficulties.
Posted Sep 16, 2025 - 00:59 PDT
Update
Our engineers have identified the issue and are working toward a fix. We will provide another update in hour or as soon as more information becomes available.
Posted Sep 15, 2025 - 23:01 PDT
Update
Our engineers have identified the issue and are working toward a fix. We will provide another update in hour or as soon as more information becomes available.
Posted Sep 15, 2025 - 20:17 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in hour or as soon as more information becomes available.
Posted Sep 15, 2025 - 18:44 PDT
Update
Our engineers are still investigating this issue with updating payment methods for billing information. As kindly mentioned previously customers may experience issues with adding and updating their payment methods. We will provide another update in an hour or as soon as more information becomes available.
Posted Sep 15, 2025 - 17:31 PDT
Investigating
Starting around 3:47pm PST on September 15th, our engineers began investigating an issue with updating payment methods for billing information. Customers may experience issues with adding and updating their payment methods. This does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.