Users are unable to login to SendGrid UI. Error "Failed to Fetch"
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the login issue has been resolved. All services are now operating normally at this time.
Posted Sep 02, 2024 - 00:42 PDT
Monitoring
Our engineers have implemented a fix and are monitoring, while users will be able to login to the SendGrid account. We will provide another update in hour or as soon as more information becomes available.
Posted Sep 02, 2024 - 00:28 PDT
Update
Our engineers identified the issue and are working towards a fix. We will provide another update very soon as more information becomes available.
Posted Sep 01, 2024 - 23:37 PDT
Identified
Our engineers identified the issue at 21:30 Pacific Time (PT) and are working toward a fix. We will provide another update very soon as more information becomes available.
Posted Sep 01, 2024 - 21:43 PDT
Investigating
We are currently investigating an issue affecting the ability of some users to log into their SendGrid accounts. Impacted users may encounter a "Failed to Fetch" error message when attempting to log in.

Please note that this issue does not affect email sending, and your outgoing mail will continue to function as expected. Our engineering team is actively working to resolve this problem.

We will provide an update within the next hour or sooner if more information becomes available.
Posted Sep 01, 2024 - 21:32 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns), Mail Sending (API v3, SMTP, API v2), and API, Statistics, Email Activity, Partners, Billing, Legacy Marketing Campaigns.