Intermittent Errors on SendGrid Plan Changes and Billing Payments
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with billing functionality has been resolved. All services are now operating normally at this time.
Posted Sep 04, 2024 - 14:38 PDT
Update
Our teams are continuing to monitor system performance and the third party fix. We will provide another update in one hour or as soon as more information becomes available.
Posted Sep 04, 2024 - 14:09 PDT
Monitoring
As of 12:41 PM PDT on 9/4/2024, the third party involved in this incident has notified that a fix deployment has been made they are monitoring system performance. We will provide another update in one hour or as soon as more information becomes available.
Posted Sep 04, 2024 - 13:16 PDT
Investigating
Due to a third party provider incident, the SendGrid platform is experiencing an issue in billing functionality as of 11:25AM PDT on 9/4/2024. Users may experience intermittent Internal 500 errors when attempting to upgrade or downgrade plans, and inability to access the billing page via the user interface. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 04, 2024 - 12:18 PDT
This incident affected: Website and Billing.