Global Stats Delayed

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed that the customers should not be observing delays any more. All services are now operating normally at this time.
Posted Dec 01, 2025 - 19:33 PST

Monitoring

Our engineers have implemented a fix and are monitoring system performance, customers should not be observing delays anymore.

We will provide another update in an hour or as soon as more information becomes available.
Posted Dec 01, 2025 - 18:52 PST

Update

We are continuing to monitor queues. Users will see stats fluctuate between 1 - 2 hour delays.
Posted Dec 01, 2025 - 11:29 PST

Identified

Our engineers have identified the issue and are currently implementing a fix.
Posted Dec 01, 2025 - 09:14 PST

Update

Our engineers are continue to investigate the issue regarding Global Stats. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 01, 2025 - 09:09 PST

Investigating

Beginning at 12/01 8:06 AM (PST) - Our engineers have identified an issue regarding SendGrid Global Stats. Affected customers may experience up to 2 hour delay for global stats to populate. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 01, 2025 - 08:24 PST
This incident affected: Statistics.