Design Editor Template Not Allowing Movement of Modules

Incident Report for SendGrid

Identified

Our engineers are continuing to investigate the issue with the Design Editor preventing module movement. Initial findings suggest Chrome's latest update (ver.147) from last Wednesday may be the cause.

For the best experience, please use the latest version of Safari or Firefox while we work on a fix.

We will provide another update as soon as more information becomes available.
Posted Apr 22, 2026 - 13:51 PDT

Update

Our engineers are continuing to investigate the issue with the Design Editor preventing module movement. Initial findings suggest Chrome's latest update (ver.147) from last Wednesday may be the cause.

For the best experience, please use the latest version of Safari or Firefox while we work on a fix.

We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 22, 2026 - 11:36 PDT

Update

Our engineers are continuing to investigate the issue with the Design Editor preventing module movement. We will continue to provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 22, 2026 - 10:41 PDT

Investigating

Starting around 8:22 AM PST on April 22nd, 2026, our engineers began investigating an issue where module movement is not functioning properly within the Design Editor. Customers may experience the inability to select modules for drag-and-drop repositioning. This does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted Apr 22, 2026 - 09:32 PDT
This incident affects: Marketing Campaigns (Marketing Campaigns) and API.